Permission denied error when building multiple projects

Topics: General
Nov 4, 2012 at 8:25 PM
Edited Nov 5, 2012 at 7:41 AM

Hi, after converting a bunch of JavaScript projects to TypeScript we have run into a significant problem.

While every project builds successfully when built individually, we get build errors like those below when multiple projects (e.g. under a solution folder) are built in parallel:

------ Rebuild All started: Project: MyProject, Configuration: Release Any CPU ------

16>  Couldn't write to file 'MyFile.js'16>EXEC : tsc.js(21005, 21) Microsoft JScript runtime error : Permission denied

16> MyProject.csproj(68,5): error MSB3073: The command ""C:\Program Files (x86)\Microsoft SDKs\TypeScript\\tsc" --module amd "File1.ts" "File2.ts"" exited with code 1.


It is not difficult to see that two or more projects, which have common <reference> includes to a shared component, are failing when attempting to compile that shared component, because the output file for that component is locked up.

How do we circumvent this problem?



Nov 5, 2012 at 4:38 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Dec 19, 2012 at 3:35 PM
Edited Dec 19, 2012 at 3:35 PM

I originally highlighted this for TS The initial error was "Permission denied".

From the error now is "Write to file failed".

We don't use TFS (as highlighted by others in the issue) and we still get this error when building multiple projects.

This is a significant problem because it is no longer possible to build a solution containing multiple TypeScript files.

Is it possible to provide an indication of when this will be fixed?


Dec 20, 2012 at 3:04 PM

Do you get the same error if you use node to run tsc.js? That may help you work around the issue until we can address it.