Compile on Save stops working from time to time

Topics: General
Sep 19, 2013 at 6:42 PM
I'm constantly having a problem where compile on save just doesn't work sometimes.

It works most of the time, but sometimes I change something and hit Ctrl+S, and the file is not updated. Hit ctrl+s multiple times and nothing.

I then type some spaces to the file just to have changes, hit ctrl+s again and it compiles again.

This was marked as 'cannot reproduce' before, but it is constant on my machine. Anyone else having this problem?
Sep 19, 2013 at 8:06 PM
I too am having this same exact problem.
Sep 20, 2013 at 5:10 PM
If that's also happening during an active debugger this maybe related (albeit unresolved): http://typescript.codeplex.com/workitem/1668
Sep 20, 2013 at 5:11 PM
In my case, I'm not debugging.
Sep 26, 2013 at 9:41 PM
We have found (and fixed) a couple of issues with compile on save, so it should be more stable in the next release. If you have a specific repro however, that will help us ensure we have the issue you are encountering known & addressed.

p.s. If you could log issues you hit in the issues section of this project (https://typescript.codeplex.com/workitem/list/advanced) that would help us track customer issues easier. The discussions forums aren't really set up for it in our workflow.

Thanks!
Sep 27, 2013 at 1:08 AM
I did that before but it was flagged as "cannot reproduce" so I came here to check if I was the only one having this problem.
Sep 30, 2013 at 8:28 AM
Same here. Compile on save isn't working reliably. Hopefully next version that billti mentions will patch it for good.
BTW, I really don't see a pattern. Sometimes works, sometimes doesn't. Furthermore sometimes works if I quickly hit ctrl+s twice. Highly annoying to the point that I usually run command line compiler after save and considering a build tool like grunt instead.

A suggestion here: provide us with some logging information so we can report back what's going on.