Visual Studio 2013 - Typescript plugin broken / missing

Topics: General
Oct 17, 2013 at 6:51 PM
The typescript plugin is not picked up by Visual Studio 2013 after installation.

On my pc, I've removed Visual Studio 2012 and the old typescript plugin.
I've installed Visual Studio 2013 Ultimate (released today on MSDN version "12.0.21005.1 REL") and the Typescript for Visual Studio plugin which the IDE links to.

Visual Studio keeps showing "Install the latest Typescript for Visual Studio" when I try to create a typescript project. Adding a typescript file under Add > New Item is also missing.

I've tried cleaning VS 2013 back off the machine, rebooting and re-installing to no avail.
I've tried uninstalling the Typescript plugin several times and reinstalling.

I also installed the Python plugin as a test as it also said "Install Python for Visual Studio" - that worked - once it was installed and VS restarted, 7 python projects are available.

The Installed Products list also updated after python, no mention of Typescript here


This is the current installed products
Microsoft Visual Studio Ultimate 2013
Version 12.0.21005.1 REL
Microsoft .NET Framework
Version 4.5.50938

Installed Version: Ultimate

Architecture and Modeling Tools 06181-004-0451022-02631
Microsoft Architecture and Modeling Tools

UML® and Unified Modeling Language™ are trademarks or registered trademarks of the Object Management Group, Inc. in the United States and other countries.

Team Explorer for Visual Studio 2013 06181-004-0451022-02631
Microsoft Team Explorer for Visual Studio 2013

Visual Basic 2013 06181-004-0451022-02631
Microsoft Visual Basic 2013

Visual C# 2013 06181-004-0451022-02631
Microsoft Visual C# 2013

Visual C++ 2013 06181-004-0451022-02631
Microsoft Visual C++ 2013

Visual F# 2013 06181-004-0451022-02631
Microsoft Visual F# 2013

Visual Studio 2013 Code Analysis Spell Checker 06181-004-0451022-02631
Microsoft® Visual Studio® 2013 Code Analysis Spell Checker

Portions of International CorrectSpell™ spelling correction system © 1993 by Lernout & Hauspie Speech Products N.V. All rights reserved.

The American Heritage® Dictionary of the English Language, Third Edition Copyright © 1992 Houghton Mifflin Company. Electronic version licensed from Lernout & Hauspie Speech Products N.V. All rights reserved.

ASP.NET Web Frameworks and Tools 2012.2 4.1.21001.0
For additional information, visit http://go.microsoft.com/fwlink/?LinkID=309563

ASP.NET Web Frameworks and Tools 2013 5.0.11001.0
For additional information, visit http://www.asp.net/

Common Azure Tools 1.0
Provides common services for use by Azure Mobile Services and Windows Azure Tools.

Microsoft Python Tools for Visual Studio 2.0.11016.00
Python Tools for Visual Studio provides intellisense, project support, project and item templates, as well as a REPL window for Python development.

Microsoft Python Tools for Visual Studio - Django Integration 2.0.11016.00
Provides templates and integration for the Django web framework.

Microsoft Python Tools for Visual Studio - Profiling Support 2.0.11016.00
Profiling support for Python projects.

Microsoft Web Developer Tools 2013 2.0.40926.0
Microsoft Web Developer Tools contains the following components:
Support for creating and opening ASP.NET web projects
Browser Link: A communication channel between Visual Studio and browsers
Editor extensions for HTML, CSS, and JavaScript
Page Inspector: Inspection tool for ASP.NET web projects
Scaffolding: A framework for building and running code generators
Server Explorer extensions for Windows Azure Web Sites
Web publishing: Extensions for publishing ASP.NET web projects to hosting providers, on-premises servers, or Windows Azure

NuGet Package Manager 2.7.40911.287
NuGet Package Manager in Visual Studio. For more information about NuGet, visit http://docs.nuget.org/.

PreEmptive Analytics Visualizer 1.2
Microsoft Visual Studio extension to visualize aggregated summaries from the PreEmptive Analytics product.

SQL Server Data Tools 12.0.30919.1
Microsoft SQL Server Data Tools

Windows Azure Mobile Services Tools 1.0
Windows Azure Mobile Services Tools
Oct 19, 2013 at 1:54 AM
Same problem here.
Oct 19, 2013 at 8:21 AM
Hi guys,

I had the same problem after uninstalling the RC versions of VS and installing the RTM version.

I figured VS RC uninstall might have left some remains of the previous plugin installation, so I uninstalled Typescript and then searched for 'Typescript' in 'Program Files (x86)' and found some suspicious looking folders hanging around in some Visual Studio folders. Sorry I can't remember the exact paths, but I was a bit pressed to get the thing working. After this I deleted those folders, re-installed Typescript and voila, it was working again.

Once again sorry for the sketchy instructions, but hope it enough to help you guy.

VC
Oct 19, 2013 at 9:36 AM
Edited Oct 19, 2013 at 9:53 AM
Hi Vcastro70

Some good advice there. I did find some old folders which I cleaned. Unfortunately, its still not detecting the plugin.
At this point bar a machine wipe or go back to VS2012, I can't think what to do.

Hopefully newer versions of the plugin can correct the problem.

Edit: Tried the following, I give up now
  • I deleted the previous download of the typescript plugin in the downloads folder
  • Uninstalled it
  • Cleaned all references to it
  • Started VS 2013
  • Went to New Project > Typescript
  • Clicked the button to get the download
  • It opened chrome
  • I installed it
  • VS 2013 doesn't register the installed, still says to download it
Oct 19, 2013 at 10:10 AM
Hello Solyad,

I think I've also found some old stuff lying around in some folder inside %APPDATA% which I also removed.
One more information though, after I successfully managed to get the plugin working, whenever I create a new Typescript language project, in the New Project dialog I still get the 'Install latest Typescript version' option, although I now have an actual project template to choose from, and when I open an existing project all is working properly.
Oct 19, 2013 at 10:15 AM
There is a few bits showing in temp in appdata. Ill clean that too.
Thanks
John
Oct 19, 2013 at 10:34 AM
Still no joy. I've cleaned every reference on the machine, bar hunting through the registry.
When I try to do a new project, it just creates an empty folder. Its just not working.
Bugged product, life should not be this hard. VS2013 is just out so hopefully theres a fix.

Thanks for all the suggestions
Oct 25, 2013 at 5:06 AM
I have same issue with VS2013 RTM, TypeScript Plugin 0.9.1 or 0.9.1.1
Oct 25, 2013 at 7:28 AM
Hello Solyad

I found a way, my VS2013 is installed in driver D, but the plugin is installed in C, so copy items about TypeScript in C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\ProjectTemplates and ItemTemplates, and copy them to the right folder in D.


Delete the ProjectTemplatesCache and ItemTemplatesCache, so VS can reload TypeScript items you just added.


Hope this helps
Oct 25, 2013 at 8:12 AM
Hi Zxcp

Ah, my installation is also split across two drives. This might be it.
I will try your solution this evening. Fantastic tip.

Perhaps the plugin just can't handle split installations at the moment.

Much appreciated
John
Coordinator
Oct 25, 2013 at 6:30 PM
Sounds like there is an issue that was recently fixed around installing TypeScript when VS was installed to a non-standard location. This should be fixed in the next release.
Nov 8, 2013 at 8:19 PM
Hello zcxp,
Your solution helped me. I installed VS on my SD drive. Once I cut and pasted the TypeScript folders to C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\ProjectTemplates and ItemTemplates and also delete the cache folders, it all works. Hopefully people will read this and not go down the path of re-installing their environment.

Thank you,
Billy
Nov 9, 2013 at 8:20 AM
Hi

It fixed it for me also.

Thanks