Rename bool type to boolean


Shouldn't the bool type be named "boolean" to match the behavior of typeof?
Closed Oct 9, 2013 at 8:50 PM by RyanCavanaugh


thorn0 wrote Oct 6, 2012 at 7:59 PM

I think both should be valid.

rwaldron wrote Oct 6, 2012 at 11:53 PM

+1 (not both)

jpoehls wrote Oct 7, 2012 at 1:00 PM

+1 not both, less is more. Consistency is king and all that.

aleewade wrote Oct 14, 2012 at 5:47 PM

+1 not both

Quango wrote Oct 15, 2012 at 2:09 PM

Had a quick look at Ecmascript harmony, sounds like Boolean may be the adopted standard, although boolean may also be accepted..

coudy wrote Nov 21, 2012 at 7:58 PM

This looks like C# heritage but I agree it violates the principle of least astonishment when coming from JavaScript, so I'd definitely rename bool to boolean while we're still in alpha.

jonturner wrote Jan 24, 2013 at 7:34 PM

Agreed - we're planning to switch to 'boolean' over the next few releases to align.

kenjiru wrote Mar 10, 2013 at 10:45 AM

Please rename it to 'boolean', otherwise it's inconsistent with the 'Boolean' data type behind it.