This project is read-only.

cannot clone git repository

Topics: General
Jan 9, 2013 at 2:04 AM

sto@hive:~/workspace$ git clone into 'typescript'...

remote: Counting objects: 6390, done.

remote: Compressing objects: 100% (2615/2615), done.

remote: Total 6390 (delta 3394), reused 6359 (delta 3382)

Receiving objects: 100% (6390/6390), 4.34 MiB | 1.46 MiB/s, done.

error: RPC failed; result=56, HTTP code = 200Resolving deltas: 100% (3394/3394), done.


anybody know how to fix this?

Jan 9, 2013 at 6:07 PM

I'd heard that some distros of Linux were having an issue because of the version mismatch between git on the Codeplex server and the git client.  Have you tried updating your git client to the latest release to see if that helps?

Jan 9, 2013 at 7:20 PM

my git version is

sto@jedi:~/workspace$ git --versiongit version

that's the latest for ubuntu 12.10

I don't have any problems with github

Jan 10, 2013 at 4:37 PM

upgrade to git and still got the same problem


what version of git is compatible with codeplex?

Jan 10, 2013 at 5:45 PM
Edited Jan 10, 2013 at 6:00 PM

Just to let you know I'm having the same problem (I'm on Ubuntu 12.04, 32bits Intel)

I also tried upgrading to Git (the Ubuntu package from the Git project) and even tried increasing the post buffer, but always got the same exception. I believe I was able to clone previous versions 0.8.0 and 0.8.1, but not anymore. 

I found some suggestions to use something else than HTTPS, but it seems Codeplex doesn't support HTTP:// or GIT:// or GIT+SSH:// protocols. 

BTW, I do use GitHub all the time, and there are no problems there. So there are scenario's where a HTTPS based clone is working on my system.

Some more info, my old fork goes fine:

git clone

My new fork (made today) goes wrong:

git clone




Jan 10, 2013 at 6:06 PM

good to know I'm not the only one with this problem. I got around this by running windows 7 on virtualbox and mounting my linux fs in virtualbox. It is odd that git on windows work but not git on linux

Jun 25, 2013 at 6:52 AM
I also getting the same exception on Ubuntu 13.04. Did anyone get a solution?
Jun 25, 2013 at 7:33 AM
The solution I finally got working was setting up a "https tunnel" to codeplex and then use git to connect to the localhost instead and let the tunnel handle the connection. Here you can find some of more details of the steps to followed:
Jun 25, 2013 at 7:41 AM
I am able to clone/ push/ pull from another repo on codeplex itself. The problem is with typescript only.
Jun 25, 2013 at 7:46 AM
As far as I understand it, it has to do with the size of the repository. If you do some searches you'll find also people using other codeplex repositories having this issue. The earlier versions of TS repository where fine, but once it grew the issue came into play.
Jun 25, 2013 at 11:19 AM
I found a solution while searching. This works for any repo on codeplex or even github. Actually while cloning with https, these require a latest version of git. The git version is not specified hence we need to build git from src(take the latest version from git's main repo.)
Refer following link for help: